Angular Material
Error after ng serve

chunk {main} main.js, main.js.map (main) 343 kB [entry] [rendered]
chunk {polyfills} polyfills.js, polyfills.js.map (polyfills) 343 kB [entry] [rendered]
chunk {runtime} runtime.js, runtime.js.map (runtime) 5.22 kB [entry] [rendered]
chunk {styles} styles.js, styles.js.map (styles) 497 kB [entry] [rendered]
chunk {vendor} vendor.js, vendor.js.map (vendor) 9.17 kB [initial] [rendered]

ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.
node_modules/rxjs/internal/types.d.ts(82,52): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(82,8smile: error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(82,92): error TS1109: Expression expected.

i 「wdm」: Failed to compile.

chunk {main} main.js, main.js.map (main) 343 kB [entry] [rendered] chunk {polyfills} polyfills.js, polyfills.js.map (polyfills) 343 kB [entry] [rendered] chunk {runtime} runtime.js, runtime.js.map (runtime) 5.22 kB [entry] [rendered] chunk {styles} styles.js, styles.js.map (styles) 497 kB [entry] [rendered] chunk {vendor} vendor.js, vendor.js.map (vendor) 9.17 kB [initial] [rendered] ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected. node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected. node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected. node_modules/rxjs/internal/types.d.ts(82,52): error TS1005: ';' expected. node_modules/rxjs/internal/types.d.ts(82,88): error TS1005: ';' expected. node_modules/rxjs/internal/types.d.ts(82,92): error TS1109: Expression expected. i 「wdm」: Failed to compile.

Try this to fix Angular Material Free Theme error...

This problem might arise due to version mismatch. To solve your problem you need to do the following changes in your package.json file.

Step 1: Go to package.json and modify "rxjs": "^6.0.0" to "rxjs": "6.0.0"

Step 2: Run npm update in your project.

**Try this to fix Angular Material Free Theme error...** This problem might arise due to version mismatch. To solve your problem you need to do the following changes in your package.json file. Step 1: Go to package.json and modify "rxjs": "^6.0.0" to "rxjs": "6.0.0" Step 2: Run npm update in your project.
7
1
2
live preview
enter atleast 50 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft